Be sure that your using Chrome, Firefox, and latest versions of Internet Explorer, but not 8/9 or earlier, when you are using My Virtual Y.